Review Board 1.7.16


Ensure internal poll is used when we ask for it

Review Request #198 - Created March 17, 2009 and submitted

Russell Bryant
/branches/1.4
13404
Reviewers
asterisk-dev
Asterisk
We have seen a number of problems caused by poll() not working properly on Mac OSX.  If you search around, you'll find a number of references to using select() instead of poll() to work around these issues.  In Asterisk, we've had poll.c which implements poll() using select() internally.  However, we were still getting reports of problems.

vadim investigated a bit and realized that at least on his system, even though we were compiling in poll.o, the system poll() was still being used.  So, the primary purpose of this patch is to ensure that we're using the internal poll() when we want it to be used.

The changes are:

1) Remove logic for when internal poll should be used from the Makefile.  Instead, put it in the configure script.  The logic in the configure script is the same as it was in the Makefile.  Ideally, we would have a functionality test for the problem, but that's not actually possible, since we would have to be able to run an application on the _target_ system to test poll() behavior.

2) Always include poll.o in the build, but it will be empty if AST_POLL_COMPAT is not defined.

3) Change uses of poll() throughout the source tree to ast_poll().  I feel that it is good practice to give the API call a new name when we are changing its behavior and not using the system version directly in all cases.  So, normally, ast_poll() is just redefined to poll().  On systems where AST_POLL_COMPAT is defined, ast_poll() is redefined to ast_internal_poll().

4) Change poll() in main/poll.c to be ast_internal_poll().

It's worth noting that any code that still uses poll() directly will work fine (if they worked fine before).  So, for example, out of tree modules that are using poll() will not stop working or anything.  However, for modules to work properly on Mac OSX, ast_poll() needs to be used.
I can not reproduce the poll() problems on my current mac laptop, but I did verify that the code compiles with AST_POLL_COMPAT defined and not defined.  I also verified that when it is defined on my mac, that asterisk -r still worked.

Also, vadim on issue #13404 tested the patch and verified that it fixed the problem for him.
Ship it!
Posted (March 17, 2009, 3:39 a.m.)

   

  
Ship it!
Posted (March 17, 2009, 4:37 a.m.)

   

  

https://reviewboard.asterisk.org/ runs on a server provided by Digium, Inc. and uses bandwidth donated to the open source Asterisk community by API Digital Communications in Huntsville, AL USA.
Please report problems with this site to asteriskteam@digium.com.